分类

安卓应用安卓游戏攻略资讯

组网技术

短距离小型网间网实验平台的搭建

作者:佚名 来源: JZ5U整理 日期:2005-8-20 22:59:32
  目前,随着网络产品更新步伐的加快,有相当一部分企事业单位都有淘汰和冗余的网络设备,如果将它们都报废或扔掉是件很可惜的事。这时,网管员们可以利用它们搭建小型的网间网实验平台,利用业余时间可以进行各种网间网操作的实践,则是个不错的主意。另外,现在有很多培训班,也需要搭建网间网实验平台,供学习网络的学员练习使用。下面的步骤就可以以最快的步骤搭建一个这样的实验平台。

  所需设备:

  1、配置用管理工作站PC机1台(带网卡),Cisco Catalyst 1900交换机1台,Cisco 2500路由器2台;

  2、背对背线缆一条(一端标明为DTE,一端标明为DCE,用于直接连接两台路由器的串口),AUI转RJ45线缆一条(用于连接Cisco 2500路由器的以太网口和Cisco Catalyst 1900交换机端口),RJ45转COM口配置线一条(用于连接Cisco 2500路由器的Console口和管理工作站的COM1口),RJ45直连线一条(用于连接管理工作站的网卡口和Cisco Catalyst 1900交换机端口)。

  设备简述:

  Cisco 2500路由器:在路由器上标明为AUI的接口用于连接以太网交换机,共有2个AUI接口,所以一台Cisco 2500路由器可直接连接两个以太网段(局域网),在进行配置时这2个端口分别称为e0和e1;标明为Serial的接口用于直接连接其他的路由器,共有2个Serial接口,所以一台Cisco 2500路由器可以连接两个广域网段,在进行配置时这2个端口分别称为s0和s1;标明为Console的接口用于连接管理工作站的串口(COM口),在第一次对路由器进行配置时要用到这个端口,即必须通过管理工作站来完成首次对路由器的配置。

  硬件连接图:

  为便于察看,图中省略了无关的细节部分,如图:



  说明:图中标明为①②③④的线缆分别为:背对背线缆、AUI转RJ45线缆、RJ45转COM口配置线和RJ45直连线。

  拓扑逻辑图:

  进行配置以前通常要用手工先画出一张拓扑逻辑图,然后对照该图来进行设备的配置。特别是在多于三台路由器的情况时,由于涉及的端口较多,如果不使用拓扑逻辑图作为辅助,常常会导致配置混乱的局面。拓扑逻辑图将给出使用的端口和大致的网络地址结构,此例拟进行配置的拓扑逻辑如图所示:



  说明:

  1、图中为r1、r2的分别对应图1中的Router1、Router2,在作配置时将它们分别命名为r1和r2;

  2、“/24”表示子网掩码为255.255.255.0,即24个二进制位;

  3、“1.1”是ip地址为192.168.1.1的简写,其他依此类推,比如3.3为192.168.3.3;

  配置路由器:

  一、使用“超级终端”工具:第一次配置路由器必须通过管理工作站(Console)来进行,一般使用操作系统自带的“超级终端”工具进行配置。在正确的进行物理连接后,按照以下步骤在操作系统中找到并打开该工具:

  开始-->程序-->附件-->通讯-->超级终端

  如果没有发现这个程序,请通过“控制面板”中的“添加/删除应用程序”进行安装。 紧接着,随意输入一个连接名称,如test,然后选“直接连接到COM1”口,单击“还原默认值”按钮自动进行终端控制台仿真参数设置,然后看到的界面就是路由器的自检界面了。按照图1显示,此时我们首先配置的是Router2;

  二、配置Router2

  为便于看到使用命令配置的全过程,当出现自检并提示是否要直接配置参数时,我们选择n(No),于是进入到命令行提示符状态:

  Router>

  此时我们就可以键入配置命令了,值得注意的是,由于Router2的s0口是连接在背对背线缆的DCE口上,所以要用clock rate配置时钟同步速率,以下凡是在“>”或“#”后面的部分均为实际键入的命令:

   Router>en
Router>conf t
Router(config)#hostname r2
   r2(config)#int e0
r2(config-if)#ip address 192.168.3.1 255.255.255.0
r2(config-if)#no shutdown
r2(config-if)#int s0
r2(config-if)#ip address 192.168.2.2 255.255.255.0
r2(config-if)#no shutdown
r2(config-if)#clock rate 56000
r2(config-if)#exit
r2(config)#ip routing
r2(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1
r2(config)#ip classless
r2(config)#exit
r2#copy run start

  三、配置Router1

  将图1中标号为③的RJ45转COM口配置线从Router2的Console口中拔下来,然后接入Router1中的Console口,在操作系统中重新打开一个新的“超级终端”会话,步骤参照(一),当出现命令提示符后键入下列命令:

   Router>en
Router#conf t
Router(config)#hostname r1
r1(config)#int e0
r1(config-if)#ip address 192.168.1.1 255.255.255.0
r1(config-if)#no shutdown
r1(config-if)#int s0
r1(config-if)#ip address 192.168.2.1 255.255.255.0
r1(config-if)#no shutdown
r1(config-if)#exit
r1(config)#ip routing
r1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
r1(config)#ip classless
r1(config)#exit
r1#copy run start

  四、配置说明  

  1、配置的一般思路是:先给路由器命名以示区分,再配置相关端口,最后配置路由;

  2、配置路由时要先使用ip routing设置允许配置路由,这与很多书本所讲和模拟器配置是完全不同的,它们常常没有这一步,而导致各种路由配置均无效;

  3、ip route 0.0.0.0 0.0.0.0 用于配置默认路由,紧跟的地址是默认路由器(对端路由器)的ip地址;

  4、ip classless命令的作用是在使用默认路由方式时进行的设置,用于告诉路由器当收到路由器不明网络的包时,将其传递给默认路由而不是简单丢弃,当对端只连在一台路由器上时,这条命令可不用;

  5、一定要用copy run start命令将配置写入NVRAM中(非易失性RAM),否则下次启动时配置将丢失。

  五、测试配置

  1、在两台路由器上,分别用ping看192.168.1.1 ,192.168.2.1 ,192.168.2.2 ,和 192.168.3.1 是否可通,192.168.1.1依照此例的配置可能是不通的,这是因为e0对应Router1上的AUI0口,如果此口没有连接到交换机,即使在路由器中e0配置好了,路由器也得不到lan协议信号,即e0端口显示为up,而line protocol为down,如果在此口再接入一台Cicso Catalyst 1900交换机则port和line protocol都将显示up;

  2、使用show命令,show命令可以简写为sh

sh cdp nei,在r2上运行此命令如果可以看到两个设备时为正常情况,一台为对端的路由器r1,另一台为交换机;

sh ip interface brie ,在r1,r2上分别运行这条命令可以查看路由器中当前各端口的port和line protocol状态,s0和e0应该这两个状态值都为up(由于1中所述原因,r1的e0口的line protocol可能为down);

sh run ,在r1,r2上用这条命令查看当前运行配置是否符合预想的配置;

sh ip route,在r1,r2上用这条命令查看是否有默认路由存在,应当分别指向对端路由器的s0口ip地址; 3、将管理工作站的ip地址指定为192.168.3.3/24,看能否telnet到192.168.3.1,如能,再将管理工作站的默认网关地址设为192.168.3.1,再一次ping 192.168.2.2和 ping 192.168.1.1看看,如可以通,则说明路由开始生效,一切正常;

  六、其他配置 完成上述步骤后,基本的实验平台环境就搭建完了,但是为了不让其他人随意改动设置,还往往要配置一下特权密码和远程登录密码,以下用r1来说明这两项配置:

  1、配置特权密码:在配置模式下用

r1(config)#enable secret

  说明:就是实际要用到的密码

  2、路由器首次配置完后,以后再进行配置往往使用远程登录(telnet)到路由器上的方式来进行,远程登录的密码设置是,先进入配置模式,然后键入以下命令:

  r1(config)#line vty 0 4
r1(config-line)#login
r1(config-line)#password
r1(config-line)#exit
r1(config)#exit
r1#copy run start

  说明:就是实际要用到的远程登录密码,配置完后必须运行最后一条命令才能使该配置立即生效。

  实践是检验真理的唯一标准,计算机网络作为实践性很强的一门科学,也只有勤动手实践,才能真正掌握它。

展开

文章推荐

应用推荐

网友评论